How do I fix issues with “composer dependencies” on a WordPress/Cpanel site? [closed]

Semi-inexperienced webmaster here running into a new problem. Recently, a client’s website started displaying the following error: Composer detected issues in your platform: Your Composer dependencies …

Can’t install “laravel-apidoc-generator” due to “Conclusion: remove doctrine/inflector 2.0.3”

I’m trying to install laravel-apidoc-generator (https://github.com/mpociot/laravel-apidoc-generator) in my latest Lumen REST API. This is my Lumen version: Lumen (8.0.1) (Laravel Components ^8.0) This …

dockerfile: `composer install –no-dev installs dev-dependencies, then deletes them straight away after

My docker-compose setup does (I think) some wierd things. I am installing from this composer.json: { “require-dev”: { “phpunit/phpunit”:”~9.0″, “squizlabs/php_codesniffer”: “~3….

why am i receiving a error when installing argon on a fresh laravel install?

I am trying to install the Argon template for laravel on a fresh install, apart from filling in the .env with the database information which works i haven’t done anything to this install of laravel, …

localhost phpMyAdmin wont open because I deleted composer folder inside it

I am new to php and usage of composer in php. I am using windows 10. While trying to delete previous installation of composer I think I have mistakenly deleted the composer folder inside phpMyAdmin. …

Why can’t I install a package despite Laravel version matching the package requirements?

I am trying to install this package https://github.com/shawnsandy/img-fly on Laravel 6.5.2 According to their composer.json, they allow to use Laravel 6.* version : “require”: { “php”: “>=7.0″…

composer global require laravel/installer

I’ve tried the first commands from the Laravel documentation composer global require laravel/installer I got error Changed current directory to /Users/bheng/.composer …

Script cache:clear returned with error code 255

I installed Symfony 4.2 via composer composer create-project Symfony/website-skeleton my-project everything works correctly, then I put the project in gitlab. a friend of mine tried to clone it on …

LARAVEL: main(): Failed opening required ‘vendorautoload.php’

I followed this documentation and I keep getting that main(): Failed opening required ‘vendorautoload.php’ error and I ran composer install but still get the same error. I’m using Laravel and I’m …

Composer uses wrong php version, but php -v shows the correct one (Ubuntu)

I’m trying to install my composer packages, but it gives me this: This package requires php >=7.0.0 but your PHP version (5.5.9) But php -v gives me this: PHP 7.0.22-0ubuntu0.16.04.1 (cli) ( NTS )…