Why can’t I install a package despite Laravel version matching the package requirements?

Tags: , ,



I am trying to install this package https://github.com/shawnsandy/img-fly on Laravel 6.5.2

According to their composer.json, they allow to use Laravel 6.* version :

"require": {
    "php": ">=7.0",
    "illuminate/support": "5.*|6.*",
    "league/glide-laravel": "1.*"
},

But on a fresh Laravel 6.5.2 version, I got this error :

 Problem 1
    - Installation request for shawnsandy/img-fly ^0.1.21 -> satisfiable by shawnsandy/img-fly[v0.1.21].
    - Conclusion: remove laravel/framework v6.6.1
    - Conclusion: don't install laravel/framework v6.6.1
    - shawnsandy/img-fly v0.1.21 requires illuminate/support 5.*

Is there anything I can do here ?

Answer

You are looking at the “master” branch, which might indeed have declared support for Laravel 6.

But the latest tagged version is 1.21, which has not. If you check the package on Packagist, you’ll see that’s what you get.

If you are feeling brave and want to install pre-release software, you could requirethedev-master` version, which has the Laravel support you want.

composer require shawnsandy/img-fly:dev-master


Source: stackoverflow