Can’t install “laravel-apidoc-generator” due to “Conclusion: remove doctrine/inflector 2.0.3”

Tags: , , ,



I’m trying to install laravel-apidoc-generator (https://github.com/mpociot/laravel-apidoc-generator) in my latest Lumen REST API.

This is my Lumen version: Lumen (8.0.1) (Laravel Components ^8.0)
This is my PHP version: PHP 7.3.22.

When I’m trying to install the apidoc-generator, I’m getting the following error message.
This is what I’m using to install: composer require mpociot/laravel-apidoc-generator

Problem 1 – Conclusion: don’t install mpociot/laravel-apidoc-generator 4.8.2 – Conclusion: don’t install mpociot/laravel-apidoc-generator 4.8.1 – Conclusion: don’t install mpociot/laravel-apidoc-generator 4.8.0 – Conclusion: remove doctrine/inflector 2.0.3 – Conclusion: don’t install doctrine/inflector 2.0.3 – illuminate/console 5.7.17 requires illuminate/support 5.7.* -> satisfiable by il…….

And also after this error, I can see this error too:

  • Conclusion: don’t install illuminate/console v8.11.2|install illuminate/console 5.7.17|install illuminate/console 5.7.18|install illuminate/console 5.7.19|install illuminate/console 5.7.x-dev|install illuminate/console 5.8.x-dev|install illuminate/console v5.7.0|install illuminate/console v5.7.1|install illuminate/console v5.7.10|install illuminate/console v5.7.11|install illuminate/console v5.7.15|install illuminate/console v5.7.2|install illuminate/console v5.7.20|install illuminate/console v5.7.21|install illuminate/console v5.7.22|install illuminate/console v5.7.23|install illuminate/console v5.7.26|install illuminate/console v5.7.27|install illuminate/console v5.7.28|install illuminate/console v5.7.3|install illuminate/console v5.7.4|install illuminate/console v5.7.5|install illuminate/console v5.7.6|install illuminate/console v5.7.7|install illuminate/console v5.7.8|install illuminate/console v5.7.9|install illuminate/console v5.8.0|install illuminate/console v5.8.11|install illuminate/console v5.8.12|install illuminate/console v5.8.14|install illuminate/console v5.8.15|install illuminate/console v5.8.17|install illuminate/console v5.8.18|install illuminate/console v5.8.19|install illuminate/console v5.8.2|install illuminate/console v5.8.20|install illuminate/console v5.8.22|install illuminate/console v5.8.24|install illuminate/console v5.8.27|install illuminate/console v5.8.28|install illuminate/console v5.8.29|install illuminate/console v5.8.3|install illuminate/console v5.8.30|install illuminate/console v5.8.31|install illuminate/console v5.8.32|install illuminate/console v5.8.33|install illuminate/console v5.8.34|install illuminate/console v5.8.35|install illuminate/console v5.8.36|install illuminate/console v5.8.4|install illuminate/console v5.8.8|install illuminate/console v5.8.9…….

So this is what I have tried so far.

  1. I tried to install a lower version of doctrine. composer require doctrine/inflector:1.4.0

It gives me following error:

Your requirements could not be resolved to an installable set of packages.
Problem 1
– Conclusion: don’t install mpociot/laravel-apidoc-generator 4.8.2
– Conclusion: don’t install mpociot/laravel-apidoc-generator 4.8.1
– Conclusion: don’t install mpociot/laravel-apidoc-generator 4.8.0
– Conclusion: remove illuminate/console v8.11.2
– Installation request for mpociot/laravel-apidoc-generator ^4.8 -> satisfiable by mpociot/laravel-apidoc-generator[4.8.0, 4.8.1, 4.8.2, v4.x-dev].
– Conclusion: don’t install illuminate/console v8.11.2
– mpociot/laravel-apidoc-generator v4.x-dev requires illuminate/console ^5.7|^6.0 -> satisfiable by illuminate/console[5.7.17, 5.7.18, 5.7.19, 5.7.x-dev, 5.8.

  1. I cleared all cache and tested again. Same error.

Is this a common error with Laravel/Lumen?
How to fix this?

Thank you in advance.

Answer

As you can see on the packagist site for that package, the package is not compatible with Laravel 8. And as you can read in their issue tracker, the maintainers recommend to use knuckleswtf/scribe instead



Source: stackoverflow